summaryrefslogtreecommitdiff
path: root/dev-python/pexpect/pexpect-2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pexpect/pexpect-2.4.ebuild')
-rw-r--r--dev-python/pexpect/pexpect-2.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pexpect/pexpect-2.4.ebuild b/dev-python/pexpect/pexpect-2.4.ebuild
new file mode 100644
index 00000000000..fe95ec3c8b2
--- /dev/null
+++ b/dev-python/pexpect/pexpect-2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+HOMEPAGE="http://pexpect.sourceforge.net/ http://pypi.python.org/pypi/pexpect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="ANSI.py fdpexpect.py FSM.py pexpect.py pxssh.py screen.py"
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r doc/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}