summaryrefslogtreecommitdiff
path: root/dev-python/pupynere/pupynere-1.0.15-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pupynere/pupynere-1.0.15-r1.ebuild')
-rw-r--r--dev-python/pupynere/pupynere-1.0.15-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pupynere/pupynere-1.0.15-r1.ebuild b/dev-python/pupynere/pupynere-1.0.15-r1.ebuild
new file mode 100644
index 00000000000..6e4bedbdfdb
--- /dev/null
+++ b/dev-python/pupynere/pupynere-1.0.15-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pupynere is a PUre PYthon NEtcdf REader"
+HOMEPAGE="http://pypi.python.org/pypi/pupynere/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" -m doctest -v "${BUILD_DIR}"/lib/pupynere.py \
+ || die "Tests fail with ${EPYTHON}"
+}