summaryrefslogtreecommitdiff
path: root/dev-python/py-bcrypt/py-bcrypt-0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py-bcrypt/py-bcrypt-0.4.ebuild')
-rw-r--r--dev-python/py-bcrypt/py-bcrypt-0.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/py-bcrypt/py-bcrypt-0.4.ebuild b/dev-python/py-bcrypt/py-bcrypt-0.4.ebuild
new file mode 100644
index 00000000000..148f9bb9122
--- /dev/null
+++ b/dev-python/py-bcrypt/py-bcrypt-0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="py-bcrypt is an implementation of the OpenBSD Blowfish password hashing algorithm"
+HOMEPAGE="https://code.google.com/p/py-bcrypt/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc64 x86"
+IUSE=""
+
+RDEPEND="!dev-python/bcrypt"
+
+DOCS=( LICENSE README TODO )
+
+python_test() {
+ distutils_install_for_testing
+ "${PYTHON}" test/test.py || die "tests failed"
+}