summaryrefslogtreecommitdiff
path: root/dev-python/py-notify/py-notify-0.3.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py-notify/py-notify-0.3.1-r1.ebuild')
-rw-r--r--dev-python/py-notify/py-notify-0.3.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/py-notify/py-notify-0.3.1-r1.ebuild b/dev-python/py-notify/py-notify-0.3.1-r1.ebuild
new file mode 100644
index 00000000000..6f1e5de989c
--- /dev/null
+++ b/dev-python/py-notify/py-notify-0.3.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for implementing the Observer programming pattern in Python"
+HOMEPAGE="http://home.gna.org/py-notify"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples test"
+
+python_test() {
+ "${PYTHON}" run-tests.py || die "Tests failed"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}