summaryrefslogtreecommitdiff
path: root/dev-python/pychart/pychart-1.39-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pychart/pychart-1.39-r1.ebuild')
-rw-r--r--dev-python/pychart/pychart-1.39-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pychart/pychart-1.39-r1.ebuild b/dev-python/pychart/pychart-1.39-r1.ebuild
new file mode 100644
index 00000000000..728380ab913
--- /dev/null
+++ b/dev-python/pychart/pychart-1.39-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P=PyChart-${PV}
+
+DESCRIPTION="Python library for creating charts"
+HOMEPAGE="http://home.gna.org/pychart/"
+SRC_URI="http://download.gna.org/pychart/${MY_P}.tar.gz
+ doc? ( http://download.gna.org/pychart/${PN}-doc.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc x86"
+IUSE="doc examples"
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/${PN}/. )
+ use examples && local EXAMPLES=( demos/. )
+
+ distutils-r1_python_install_all
+}