summaryrefslogtreecommitdiff
path: root/dev-python/pychef/pychef-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pychef/pychef-0.2.1.ebuild')
-rw-r--r--dev-python/pychef/pychef-0.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pychef/pychef-0.2.1.ebuild b/dev-python/pychef/pychef-0.2.1.ebuild
new file mode 100644
index 00000000000..088d0410773
--- /dev/null
+++ b/dev-python/pychef/pychef-0.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/coderanger/pychef"
+SRC_URI="mirror://pypi/P/PyChef/PyChef-${PV}.tar.gz"
+S="${WORKDIR}/PyChef-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/versiontools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}