summaryrefslogtreecommitdiff
path: root/dev-python/pycipher/pycipher-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycipher/pycipher-0.2.ebuild')
-rw-r--r--dev-python/pycipher/pycipher-0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pycipher/pycipher-0.2.ebuild b/dev-python/pycipher/pycipher-0.2.ebuild
new file mode 100644
index 00000000000..d298359305c
--- /dev/null
+++ b/dev-python/pycipher/pycipher-0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python
+
+DESCRIPTION="A Python module that implements several well-known classical cipher algorithms"
+HOMEPAGE="http://pycipher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.py"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ installation() {
+ insinto $(python_get_sitedir)
+ newins "${DISTDIR}/${P}.py" ${PN}.py
+ }
+ python_execute_function installation
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}.py
+}