summaryrefslogtreecommitdiff
path: root/dev-python/pyenchant/pyenchant-1.6.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyenchant/pyenchant-1.6.6.ebuild')
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyenchant/pyenchant-1.6.6.ebuild b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
new file mode 100644
index 00000000000..948f2d38430
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="http://pyenchant.sourceforge.net http://pypi.python.org/pypi/pyenchant"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="
+ >=app-text/enchant-${PV%.*}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
+ ewarn "Disabling tests due to missing en_US.UTF-8 locale"
+ else
+ esetup.py test
+ fi
+}