summaryrefslogtreecommitdiff
path: root/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch')
-rw-r--r--dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch b/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
new file mode 100644
index 00000000000..9b084616c87
--- /dev/null
+++ b/dev-python/pyfltk/files/pyfltk-1.3.0-linux-3.x-detection.patch
@@ -0,0 +1,15 @@
+http://bugs.gentoo.org/show_bug.cgi?id=375253
+
+http://lipyrary.blogspot.com/2011/09/python-and-linux-kernel-30-sysplatform.html
+
+--- setup.py
++++ setup.py
+@@ -76,7 +76,7 @@
+ lib_dir_list = [fltk_lib_dir]
+ lib_list = ["fltk", "kernel32", "user32", "gdi32", "winspool", "comdlg32", "Comctl32", "advapi32", "shell32", "oleaut32", "odbc32", "odbccp32", "stdc++", "msvcr71"]
+ #link_arg_list=["-Wl,--enable-runtime-pseudo-reloc", "-Wl,--enable-auto-import"]
+-elif sys.platform == 'linux2':
++elif sys.platform.startswith('linux'):
+ print "Building for Linux"
+ # ugly hack to force distutils to use g++ instead of gcc for linking
+ from distutils import sysconfig