summaryrefslogtreecommitdiff
path: root/dev-python/pygooglevoice/pygooglevoice-0.5-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygooglevoice/pygooglevoice-0.5-r2.ebuild')
-rw-r--r--dev-python/pygooglevoice/pygooglevoice-0.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pygooglevoice/pygooglevoice-0.5-r2.ebuild b/dev-python/pygooglevoice/pygooglevoice-0.5-r2.ebuild
new file mode 100644
index 00000000000..b81e3a4a21c
--- /dev/null
+++ b/dev-python/pygooglevoice/pygooglevoice-0.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Bindings for the Google Voice API"
+HOMEPAGE="http://code.google.com/p/pygooglevoice/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz
+ http://${PN}.googlecode.com/files/${P}-extras.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="app-arch/unzip"
+
+# Requires interactive login
+RESTRICT="test"
+
+PATCH=( "${FILESDIR}"/${P}-auth.patch )
+
+python_test() {
+ "${PYTHON}" googlevoice/tests.py
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/doc/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}