summaryrefslogtreecommitdiff
path: root/dev-python/pygpgme/pygpgme-0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygpgme/pygpgme-0.3-r1.ebuild')
-rw-r--r--dev-python/pygpgme/pygpgme-0.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pygpgme/pygpgme-0.3-r1.ebuild b/dev-python/pygpgme/pygpgme-0.3-r1.ebuild
new file mode 100644
index 00000000000..8510bb2e486
--- /dev/null
+++ b/dev-python/pygpgme/pygpgme-0.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for the GPGME library"
+HOMEPAGE="https://launchpad.net/pygpgme"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed \
+ -e 's/#include <gpgme\.h>/#include <gpgme\/gpgme\.h>/' \
+ -i "${S}/src/pygpgme.h" || die
+ sed \
+ -e 's/suite.addTest(tests.test_sign_verify.test_suite())/#\0/' \
+ -e 's/suite.addTest(tests.test_encrypt_decrypt.test_suite())/#\0/' \
+ -e 's/suite.addTest(tests.test_passphrase.test_suite())/#\0/' \
+ -i "${S}/tests/__init__.py" || die
+ distutils-r1_python_prepare_all
+}