summaryrefslogtreecommitdiff
path: root/dev-python/pygsl/pygsl-0.9.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygsl/pygsl-0.9.5-r1.ebuild')
-rw-r--r--dev-python/pygsl/pygsl-0.9.5-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pygsl/pygsl-0.9.5-r1.ebuild b/dev-python/pygsl/pygsl-0.9.5-r1.ebuild
new file mode 100644
index 00000000000..08a36b8a9f6
--- /dev/null
+++ b/dev-python/pygsl/pygsl-0.9.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the GNU scientific library (gsl)"
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="sci-libs/gsl
+ dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+# Testsuite written to be run post install
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}