summaryrefslogtreecommitdiff
path: root/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild')
-rw-r--r--dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild b/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild
new file mode 100644
index 00000000000..ffcb0dd8d31
--- /dev/null
+++ b/dev-python/pyid3lib/pyid3lib-0.5.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Module for manipulating ID3 tags in Python"
+HOMEPAGE="http://pyid3lib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+DEPEND="media-libs/id3lib"
+RDEPEND="${DEPEND}"
+
+PYTHON_CXXFLAGS=("2.* + -fno-strict-aliasing")
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${P}-gcc-4.4.patch"
+ epatch "${FILESDIR}/${P}-py25.patch"
+}
+
+src_install() {
+ distutils_src_install
+ dohtml doc.html || die "dohtml failed"
+}