summaryrefslogtreecommitdiff
path: root/dev-python/pyml/pyml-0.7.13.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyml/pyml-0.7.13.2-r1.ebuild')
-rw-r--r--dev-python/pyml/pyml-0.7.13.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyml/pyml-0.7.13.2-r1.ebuild b/dev-python/pyml/pyml-0.7.13.2-r1.ebuild
new file mode 100644
index 00000000000..a2208f1ecbf
--- /dev/null
+++ b/dev-python/pyml/pyml-0.7.13.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MYP=PyML-${PV}
+
+DESCRIPTION="Python machine learning package"
+HOMEPAGE="http://pyml.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ pushd data > /dev/null
+ "${PYTHON}" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || die "tests failed"
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
+}