summaryrefslogtreecommitdiff
path: root/dev-python/pymysql/pymysql-0.6.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pymysql/pymysql-0.6.3.ebuild')
-rw-r--r--dev-python/pymysql/pymysql-0.6.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pymysql/pymysql-0.6.3.ebuild b/dev-python/pymysql/pymysql-0.6.3.ebuild
new file mode 100644
index 00000000000..12e24a0336c
--- /dev/null
+++ b/dev-python/pymysql/pymysql-0.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2014-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="PyMySQL"
+DESCRIPTION="Pure-Python MySQL Driver"
+HOMEPAGE="http://www.pymysql.org/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+S=${WORKDIR}/${MY_PN}-${P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# While tests exist, they require an unsecure server to run without manual config file
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} runtests.py || die
+}