summaryrefslogtreecommitdiff
path: root/dev-python/pynut/pynut-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pynut/pynut-1.2.ebuild')
-rw-r--r--dev-python/pynut/pynut-1.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pynut/pynut-1.2.ebuild b/dev-python/pynut/pynut-1.2.ebuild
new file mode 100644
index 00000000000..895bc47de0c
--- /dev/null
+++ b/dev-python/pynut/pynut-1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit python
+
+DESCRIPTION="An abstraction class written in Python to access NUT (Network UPS Tools) server"
+HOMEPAGE="http://www.lestat.st/informatique/projets/pynut-en/"
+SRC_URI="http://www.lestat.st/_media/informatique/projets/pynut/python-${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/python-${P}"
+
+src_install() {
+ installation() {
+ insinto $(python_get_sitedir)
+ doins PyNUT.py
+ }
+ python_execute_function -q installation
+
+ dodoc README
+}
+
+pkg_postinst() {
+ python_mod_optimize PyNUT.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup PyNUT.py
+}