summaryrefslogtreecommitdiff
path: root/dev-python/pyproj/pyproj-1.9.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyproj/pyproj-1.9.3-r1.ebuild')
-rw-r--r--dev-python/pyproj/pyproj-1.9.3-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyproj/pyproj-1.9.3-r1.ebuild b/dev-python/pyproj/pyproj-1.9.3-r1.ebuild
new file mode 100644
index 00000000000..f563b867855
--- /dev/null
+++ b/dev-python/pyproj/pyproj-1.9.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to PROJ.4 library"
+HOMEPAGE="http://code.google.com/p/pyproj/ http://pypi.python.org/pypi/pyproj"
+SRC_URI="http://pyproj.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="doc"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}