summaryrefslogtreecommitdiff
path: root/dev-python/pyregion/pyregion-1.1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyregion/pyregion-1.1.4.ebuild')
-rw-r--r--dev-python/pyregion/pyregion-1.1.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyregion/pyregion-1.1.4.ebuild b/dev-python/pyregion/pyregion-1.1.4.ebuild
new file mode 100644
index 00000000000..58ccdaabf30
--- /dev/null
+++ b/dev-python/pyregion/pyregion-1.1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+DESCRIPTION="Python module to parse ds9 region file"
+HOMEPAGE="http://leejjoon.github.com/pyregion/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT"
+
+IUSE="examples"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ || ( dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pyrex[${PYTHON_USEDEP}] )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}