summaryrefslogtreecommitdiff
path: root/dev-python/pysaml2/pysaml2-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysaml2/pysaml2-2.1.0.ebuild')
-rw-r--r--dev-python/pysaml2/pysaml2-2.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pysaml2/pysaml2-2.1.0.ebuild b/dev-python/pysaml2/pysaml2-2.1.0.ebuild
new file mode 100644
index 00000000000..90982807ee9
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
+HOMEPAGE="https://github.com/rohe/pysaml2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/repoze-who[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"