summaryrefslogtreecommitdiff
path: root/dev-python/pysctp/pysctp-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysctp/pysctp-0.6.ebuild')
-rw-r--r--dev-python/pysctp/pysctp-0.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pysctp/pysctp-0.6.ebuild b/dev-python/pysctp/pysctp-0.6.ebuild
new file mode 100644
index 00000000000..d64e6678394
--- /dev/null
+++ b/dev-python/pysctp/pysctp-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="PySCTP gives access to the SCTP transport protocol from Python"
+HOMEPAGE="https://github.com/philpraxis/pysctp"
+SRC_URI="https://github.com/philpraxis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-misc/lksctp-tools"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ rm -v "${D}usr/_sctp.h"
+ dodoc test_local_cnx.py test_remote_cnx.py
+}