summaryrefslogtreecommitdiff
path: root/dev-python/pystatgrab/pystatgrab-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pystatgrab/pystatgrab-0.6.ebuild')
-rw-r--r--dev-python/pystatgrab/pystatgrab-0.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pystatgrab/pystatgrab-0.6.ebuild b/dev-python/pystatgrab/pystatgrab-0.6.ebuild
new file mode 100644
index 00000000000..2a1f2b9e53f
--- /dev/null
+++ b/dev-python/pystatgrab/pystatgrab-0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION=" pystatgrab is a set of Python bindings for the libstatgrab library"
+HOMEPAGE="http://www.i-scream.org/pystatgrab/"
+SRC_URI="http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/pystatgrab/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/libstatgrab-0.91"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" test.py || die
+}