summaryrefslogtreecommitdiff
path: root/dev-python/python-cdb/python-cdb-0.34-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-cdb/python-cdb-0.34-r1.ebuild')
-rw-r--r--dev-python/python-cdb/python-cdb-0.34-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-cdb/python-cdb-0.34-r1.ebuild b/dev-python/python-cdb/python-cdb-0.34-r1.ebuild
new file mode 100644
index 00000000000..d823701a2f4
--- /dev/null
+++ b/dev-python/python-cdb/python-cdb-0.34-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python extension module for cdb"
+SRC_URI="http://pilcrow.madison.wi.us/python-cdb/${P}.tar.gz"
+HOMEPAGE="http://pilcrow.madison.wi.us/#pycdb"
+
+SLOT="0"
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="|| ( dev-db/cdb dev-db/tinycdb )"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${PYTHON}" setup.py build -b "build-${PYTHON_ABI}" install --home "${T}/test-${PYTHON_ABI}" || return 1
+ # This is not really intended as test but it is better than nothing.
+ "${PYTHON}" < Example
+}