summaryrefslogtreecommitdiff
path: root/dev-python/python-cdb/python-cdb-0.34.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-cdb/python-cdb-0.34.ebuild')
-rw-r--r--dev-python/python-cdb/python-cdb-0.34.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-cdb/python-cdb-0.34.ebuild b/dev-python/python-cdb/python-cdb-0.34.ebuild
new file mode 100644
index 00000000000..72a65d4d1d4
--- /dev/null
+++ b/dev-python/python-cdb/python-cdb-0.34.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+DESCRIPTION="A Python extension module for cdb"
+SRC_URI="http://pilcrow.madison.wi.us/python-cdb/${P}.tar.gz"
+HOMEPAGE="http://pilcrow.madison.wi.us/#pycdb"
+
+SLOT="0"
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="amd64 arm ia64 ppc sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="|| ( dev-db/cdb dev-db/tinycdb )"
+RDEPEND="${DEPEND}"
+
+DOCS="Example"
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home "${T}/test-${PYTHON_ABI}" || return 1
+ # This is not really intended as test but it is better than nothing.
+ PYTHONPATH="${T}/test-${PYTHON_ABI}/lib/python" "$(PYTHON)" < Example
+ }
+ python_execute_function testing
+}