summaryrefslogtreecommitdiff
path: root/dev-python/python-daap/python-daap-0.7.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-daap/python-daap-0.7.1-r1.ebuild')
-rw-r--r--dev-python/python-daap/python-daap-0.7.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-daap/python-daap-0.7.1-r1.ebuild b/dev-python/python-daap/python-daap-0.7.1-r1.ebuild
new file mode 100644
index 00000000000..3fc3cbb84be
--- /dev/null
+++ b/dev-python/python-daap/python-daap-0.7.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="PythonDaap-${PV}"
+
+DESCRIPTION="PyDaap is a DAAP client implemented in Python, based on PyTunes"
+HOMEPAGE="http://jerakeen.org/code/pythondaap"
+SRC_URI="http://jerakeen.org/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}