summaryrefslogtreecommitdiff
path: root/dev-python/python-digest/python-digest-1.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-digest/python-digest-1.7-r1.ebuild')
-rw-r--r--dev-python/python-digest/python-digest-1.7-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-digest/python-digest-1.7-r1.ebuild b/dev-python/python-digest/python-digest-1.7-r1.ebuild
new file mode 100644
index 00000000000..73528d95a5f
--- /dev/null
+++ b/dev-python/python-digest/python-digest-1.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library to aid in implementing HTTP Digest Authentication"
+HOMEPAGE="http://pypi.python.org/pypi/python-digest/ https://bitbucket.org/akoha/python-digest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="amd64 x86"
+IUSE="test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PATCHES=( "${FILESDIR}"/${P}-unittest.patch )
+
+python_test() {
+ "${PYTHON}" ${PN/-/_}/tests.py || die "Tests failed under ${EPYTHON}"
+}