summaryrefslogtreecommitdiff
path: root/dev-python/python-distutils-extra/python-distutils-extra-2.33.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-distutils-extra/python-distutils-extra-2.33.ebuild')
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.33.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.33.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.33.ebuild
new file mode 100644
index 00000000000..e85d8ed4cf0
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.33.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="You can integrate gettext support, themed icons and scrollkeeper based documentation in distutils"
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="http://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="doc/FAQ doc/README doc/setup.cfg.example doc/setup.py.example"
+PYTHON_MODNAME="DistUtilsExtra"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable broken tests.
+ sed \
+ -e "s/test_desktop/_&/" \
+ -e "s/test_po(/_&/" \
+ -e "s/test_policykit/_&/" \
+ -e "s/test_requires_provides/_&/" \
+ -i test/auto.py
+}
+
+src_test() {
+ # 5 tests fail with disabled byte-compilation.
+ python_enable_pyc
+
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/auto.py
+ }
+ python_execute_function testing
+
+ python_disable_pyc
+}