summaryrefslogtreecommitdiff
path: root/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild')
-rw-r--r--dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild b/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild
new file mode 100644
index 00000000000..c111ce46fdc
--- /dev/null
+++ b/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="A Python extension for iwscan access"
+HOMEPAGE="http://projects.otaku42.de/browser/python-iwscan"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="net-wireless/wireless-tools"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-wireless-tools-30.patch"
+)
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}