summaryrefslogtreecommitdiff
path: root/dev-python/python-mhash/python-mhash-1.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-mhash/python-mhash-1.4-r1.ebuild')
-rw-r--r--dev-python/python-mhash/python-mhash-1.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-mhash/python-mhash-1.4-r1.ebuild b/dev-python/python-mhash/python-mhash-1.4-r1.ebuild
new file mode 100644
index 00000000000..f0f171e442e
--- /dev/null
+++ b/dev-python/python-mhash/python-mhash-1.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python interface to libmhash"
+HOMEPAGE="http://mhash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 x86 ~ppc-aix ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="app-crypt/mhash"
+RDEPEND="${DEPEND}"
+
+python_configure_all() {
+ # Note: review this when py3 is supported
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}