summaryrefslogtreecommitdiff
path: root/dev-python/python-systemd/python-systemd-230.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-systemd/python-systemd-230.ebuild')
-rw-r--r--dev-python/python-systemd/python-systemd-230.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-systemd/python-systemd-230.ebuild b/dev-python/python-systemd/python-systemd-230.ebuild
new file mode 100644
index 00000000000..3ea466f5a59
--- /dev/null
+++ b/dev-python/python-systemd/python-systemd-230.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/systemd/python-systemd"
+SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-apps/systemd"
+RDEPEND="${DEPEND}
+ !sys-apps/systemd[python(-)]"
+
+src_compile() {
+ emake systemd/id128-constants.h
+ distutils-r1_src_compile
+}