summaryrefslogtreecommitdiff
path: root/dev-python/python-tvrage/python-tvrage-0.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-tvrage/python-tvrage-0.4.1.ebuild')
-rw-r--r--dev-python/python-tvrage/python-tvrage-0.4.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-tvrage/python-tvrage-0.4.1.ebuild b/dev-python/python-tvrage/python-tvrage-0.4.1.ebuild
new file mode 100644
index 00000000000..299ed21757d
--- /dev/null
+++ b/dev-python/python-tvrage/python-tvrage-0.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python client for the tvrage.com XML API"
+HOMEPAGE="https://github.com/ckreutzer/python-tvrage"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${PYTHON}" tests/api_tests.py || die "Testing failed with ${EPYTHON}"
+}