summaryrefslogtreecommitdiff
path: root/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-xlib/python-xlib-0.15_rc1.ebuild')
-rw-r--r--dev-python/python-xlib/python-xlib-0.15_rc1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild b/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
new file mode 100644
index 00000000000..c2131864078
--- /dev/null
+++ b/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="http://python-xlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86"
+IUSE=""
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="Xlib"
+
+src_test() {
+ cd test
+ testing() {
+ local return_status="0" test
+ for test in *.py; do
+ echo "Running ${test}..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" || return_status="1"
+ done
+ return "${return_status}"
+ }
+ python_execute_function testing
+}