summaryrefslogtreecommitdiff
path: root/dev-python/qserve/qserve-0.2.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qserve/qserve-0.2.8-r1.ebuild')
-rw-r--r--dev-python/qserve/qserve-0.2.8-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/qserve/qserve-0.2.8-r1.ebuild b/dev-python/qserve/qserve-0.2.8-r1.ebuild
new file mode 100644
index 00000000000..ed0a43bd108
--- /dev/null
+++ b/dev-python/qserve/qserve-0.2.8-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A job queue server"
+HOMEPAGE="https://github.com/pediapress/qserve http://pypi.python.org/pypi/qserve/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/gevent[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}