summaryrefslogtreecommitdiff
path: root/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild')
-rw-r--r--dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild b/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
new file mode 100644
index 00000000000..9bbf4a50360
--- /dev/null
+++ b/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for Requests"
+HOMEPAGE="https://github.com/requests/requests-oauthlib"
+SRC_URI="https://github.com/requests/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]"
+
+#Refrain from a doc build for now
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_test() {
+ esetup.py test
+}