summaryrefslogtreecommitdiff
path: root/dev-python/setuptools-git/setuptools-git-1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/setuptools-git/setuptools-git-1.1.ebuild')
-rw-r--r--dev-python/setuptools-git/setuptools-git-1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/setuptools-git/setuptools-git-1.1.ebuild b/dev-python/setuptools-git/setuptools-git-1.1.ebuild
new file mode 100644
index 00000000000..548fae8bc79
--- /dev/null
+++ b/dev-python/setuptools-git/setuptools-git-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Setuptools revision control system plugin for Git"
+HOMEPAGE="https://github.com/wichert/setuptools-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-vcs/git"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ git config --global user.name "test user" || die
+ git config --global user.email "test@email.com" || die
+ esetup.py test
+ retr=$?
+}