summaryrefslogtreecommitdiff
path: root/dev-python/shm/files/shm-1.2.2-compiler.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/shm/files/shm-1.2.2-compiler.patch')
-rw-r--r--dev-python/shm/files/shm-1.2.2-compiler.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-python/shm/files/shm-1.2.2-compiler.patch b/dev-python/shm/files/shm-1.2.2-compiler.patch
new file mode 100644
index 00000000000..e9e1bd22a3a
--- /dev/null
+++ b/dev-python/shm/files/shm-1.2.2-compiler.patch
@@ -0,0 +1,11 @@
+--- setup.py 2010-06-26 03:29:30.000000000 +0200
++++ setup.py 2010-06-26 03:30:10.000000000 +0200
+@@ -84,7 +84,7 @@
+ filename = "%d.c" % i
+ file(path + filename, "w").write(src % ('_' * i))
+
+- cmd = ["cc", "-c", "-o", "/dev/null", "%s" % path + filename]
++ cmd = [os.environ.get("CC", "cc"), "-c", "-o", "/dev/null", "%s" % path + filename]
+
+ po = popen2.Popen4(cmd)
+ if not po.wait(): underscores[i] = True