summaryrefslogtreecommitdiff
path: root/dev-python/simpy/simpy-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/simpy/simpy-3.0.3.ebuild')
-rw-r--r--dev-python/simpy/simpy-3.0.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/simpy/simpy-3.0.3.ebuild b/dev-python/simpy/simpy-3.0.3.ebuild
new file mode 100644
index 00000000000..1899aa7e85c
--- /dev/null
+++ b/dev-python/simpy/simpy-3.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/simpy/SimPy}"
+
+DESCRIPTION="Simulation in Python is an object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="http://simpy.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -vv || die
+}
+
+python_install_all() {
+ DOCS=( AUTHORS.txt CHANGES.txt README.txt )
+ if use doc; then
+ pushd docs > /dev/null || die
+ PYTHONPATH=.. emake html && HTML_DOCS=( docs/_build/html/. docs/_build/doctrees/. )
+ popd > /dev/null || die
+ fi
+
+ distutils-r1_python_install_all
+}