summaryrefslogtreecommitdiff
path: root/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/singledispatch/singledispatch-3.4.0.3.ebuild')
-rw-r--r--dev-python/singledispatch/singledispatch-3.4.0.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild b/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
new file mode 100644
index 00000000000..3cb00c89e9e
--- /dev/null
+++ b/dev-python/singledispatch/singledispatch-3.4.0.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to bring functools.singledispatch from Python 3.4 to Python 2.6-3.3"
+HOMEPAGE="http://docs.python.org/3/library/functools.html#functools.singledispatch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PF}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"