summaryrefslogtreecommitdiff
path: root/dev-python/smmap/smmap-0.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/smmap/smmap-0.8.3.ebuild')
-rw-r--r--dev-python/smmap/smmap-0.8.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/smmap/smmap-0.8.3.ebuild b/dev-python/smmap/smmap-0.8.3.ebuild
new file mode 100644
index 00000000000..661af0d7b2b
--- /dev/null
+++ b/dev-python/smmap/smmap-0.8.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure git implementation of a sliding window memory map manager"
+HOMEPAGE="
+ http://pypi.python.org/pypi/smmap
+ https://github.com/Byron/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}]
+ )
+ "
+RDEPEND=""
+
+python_test() {
+ nosetests || die
+}