summaryrefslogtreecommitdiff
path: root/dev-python/socketpool/socketpool-0.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/socketpool/socketpool-0.5.2.ebuild')
-rw-r--r--dev-python/socketpool/socketpool-0.5.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/socketpool/socketpool-0.5.2.ebuild b/dev-python/socketpool/socketpool-0.5.2.ebuild
new file mode 100644
index 00000000000..45e2e7bd508
--- /dev/null
+++ b/dev-python/socketpool/socketpool-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple Python socket pool"
+HOMEPAGE="http://github.com/benoitc/socketpool/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+LICENSE="|| ( MIT public-domain )"
+SLOT="0"
+
+RDEPEND="dev-python/gevent"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples
+ insinto usr/share/doc/${P}
+ doins -r examples/
+ fi
+}
+src_test() {
+ PYTHONPATH=. py.test tests/test_pool_01.py
+}