summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-googleanalytics
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-googleanalytics')
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch4
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild27
2 files changed, 29 insertions, 2 deletions
diff --git a/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch b/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
index b3b9f58d1b2..a45ae42b188 100644
--- a/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
+++ b/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
@@ -1,6 +1,6 @@
https://bugs.gentoo.org/show_bug.cgi?id=429914
---- setup.py
-+++ setup.py
+--- a/setup.py
++++ b/setup.py
@@ -1,10 +1,11 @@
# -*- coding: utf-8 -*-
diff --git a/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild
new file mode 100644
index 00000000000..ab505c55c22
--- /dev/null
+++ b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension googleanalytics"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/setup.py.utf-8.patch" )
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}