summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.4.ebuild')
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.4.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.4.ebuild
new file mode 100644
index 00000000000..93d63c6294b
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension to embed UML diagram by using PlantUML"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND="
+ >=dev-python/sphinx-1.1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ media-gfx/plantuml
+"
+
+DOCS="README.rst"