summaryrefslogtreecommitdiff
path: root/dev-python/tagpy/tagpy-2013.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tagpy/tagpy-2013.1.ebuild')
-rw-r--r--dev-python/tagpy/tagpy-2013.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/tagpy/tagpy-2013.1.ebuild b/dev-python/tagpy/tagpy-2013.1.ebuild
new file mode 100644
index 00000000000..ccea56b1bfd
--- /dev/null
+++ b/dev-python/tagpy/tagpy-2013.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Bindings for TagLib"
+HOMEPAGE="http://mathema.tician.de//software/tagpy http://pypi.python.org/pypi/tagpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-libs/boost-1.49.0[python]
+ >=media-libs/taglib-1.7.2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_configure() {
+ "${PYTHON}" configure.py \
+ --taglib-inc-dir="${EPREFIX}/usr/include/taglib" \
+ --boost-python-libname="boost_python-${EPYTHON#python}"
+ distutils-r1_python_configure
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( test/* )
+
+ distutils-r1_python_install_all
+}