summaryrefslogtreecommitdiff
path: root/dev-python/testfixtures/testfixtures-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testfixtures/testfixtures-3.0.0.ebuild')
-rw-r--r--dev-python/testfixtures/testfixtures-3.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/testfixtures/testfixtures-3.0.0.ebuild b/dev-python/testfixtures/testfixtures-3.0.0.ebuild
new file mode 100644
index 00000000000..088b0285f3f
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-3.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="http://pypi.python.org/pypi/testfixtures/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND=" dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7) )
+ test? ( dev-python/manuel[${PYTHON_USEDEP}] )"
+
+# Prevent un-needed download during build, fix Makefile for doc build
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+
+python_prepare() {
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v ${PN}/tests || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}