summaryrefslogtreecommitdiff
path: root/dev-python/theano/theano-0.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/theano/theano-0.6.0.ebuild')
-rw-r--r--dev-python/theano/theano-0.6.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/theano/theano-0.6.0.ebuild b/dev-python/theano/theano-0.6.0.ebuild
new file mode 100644
index 00000000000..148376601c9
--- /dev/null
+++ b/dev-python/theano/theano-0.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+MYPN=Theano
+MYP=${MYPN}-$(replace_version_separator 3 '')
+
+DESCRIPTION="Python library to define and optimize multi-dimensional arrays mathematical expressions"
+HOMEPAGE="https://github.com/Theano/Theano"
+LICENSE="BSD"
+
+SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SLOT="0"
+IUSE="test"
+
+RDEPEND="sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ nosetests || die
+}