summaryrefslogtreecommitdiff
path: root/dev-python/tpg/tpg-3.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tpg/tpg-3.2.2-r1.ebuild')
-rw-r--r--dev-python/tpg/tpg-3.2.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/tpg/tpg-3.2.2-r1.ebuild b/dev-python/tpg/tpg-3.2.2-r1.ebuild
new file mode 100644
index 00000000000..6dc7eebee70
--- /dev/null
+++ b/dev-python/tpg/tpg-3.2.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# py2.6 doesn't pass tests
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_P="TPG-${PV}"
+
+DESCRIPTION="Toy Parser Generator for Python"
+HOMEPAGE="http://christophe.delord.free.fr/tpg/index.html"
+SRC_URI="http://christophe.delord.free.fr/tpg/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc x86"
+IUSE="doc examples"
+DOCS=( ChangeLog README THANKS doc/tpg.pdf )
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${PYTHON}" tpg_tests.py -v || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}