summaryrefslogtreecommitdiff
path: root/dev-python/traits/traits-4.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/traits/traits-4.5.0.ebuild')
-rw-r--r--dev-python/traits/traits-4.5.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/traits/traits-4.5.0.ebuild b/dev-python/traits/traits-4.5.0.ebuild
deleted file mode 100644
index aa0e34305e3..00000000000
--- a/dev-python/traits/traits-4.5.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Enthought Tool Suite: Explicitly typed attributes for Python"
-HOMEPAGE="http://docs.enthought.com/traits/
- https://github.com/enthought/traits
- https://pypi.org/project/traits/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-
-python_prepare_all() {
- sed -i -e "s/'-O3'//g" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests || die
-}