summaryrefslogtreecommitdiff
path: root/dev-python/tweepy/tweepy-2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tweepy/tweepy-2.3.ebuild')
-rw-r--r--dev-python/tweepy/tweepy-2.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/tweepy/tweepy-2.3.ebuild b/dev-python/tweepy/tweepy-2.3.ebuild
new file mode 100644
index 00000000000..7968f4eeded
--- /dev/null
+++ b/dev-python/tweepy/tweepy-2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A Python library for accessing the Twitter API "
+HOMEPAGE="http://tweepy.github.com/"
+SRC_URI="https://github.com/tweepy/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+#RESTRICT="test" #missing a required dep frpm portage
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Required to avoid file collisions at install
+ sed \
+ -e "/find_packages/s:]:,'tests.*','examples']:g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m tests || die "Tests failed"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}