summaryrefslogtreecommitdiff
path: root/dev-python/tweepy
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tweepy')
-rw-r--r--dev-python/tweepy/tweepy-2.3.ebuild16
-rw-r--r--dev-python/tweepy/tweepy-3.3.0.ebuild5
2 files changed, 15 insertions, 6 deletions
diff --git a/dev-python/tweepy/tweepy-2.3.ebuild b/dev-python/tweepy/tweepy-2.3.ebuild
index 198729335bd..6e0482ea650 100644
--- a/dev-python/tweepy/tweepy-2.3.ebuild
+++ b/dev-python/tweepy/tweepy-2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,9 +17,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"
-#RESTRICT="test" #missing a required dep frpm portage
+# online tests
+RESTRICT="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/httreplay[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
python_prepare_all() {
# Required to avoid file collisions at install
@@ -30,7 +36,9 @@ python_prepare_all() {
}
python_test() {
- "${PYTHON}" -m tests || die "Tests failed"
+ nosetests -v \
+ tests.test_api tests.test_streaming \
+ tests.test_cursors tests.test_utils || die
}
python_compile_all() {
diff --git a/dev-python/tweepy/tweepy-3.3.0.ebuild b/dev-python/tweepy/tweepy-3.3.0.ebuild
index 16cbb91c967..263fad6e34b 100644
--- a/dev-python/tweepy/tweepy-3.3.0.ebuild
+++ b/dev-python/tweepy/tweepy-3.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -22,6 +22,7 @@ RESTRICT="test" #missing in tarball
DEPEND="
dev-python/pip[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
"
RDEPEND="
>=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
@@ -37,7 +38,7 @@ python_prepare_all() {
}
python_test() {
- "${PYTHON}" -m tests || die "Tests failed"
+ nosetests -v -c tests/travis-tests.cfg || die
}
python_compile_all() {