summaryrefslogtreecommitdiff
path: root/dev-python/twython/twython-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twython/twython-3.2.0.ebuild')
-rw-r--r--dev-python/twython/twython-3.2.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/twython/twython-3.2.0.ebuild b/dev-python/twython/twython-3.2.0.ebuild
new file mode 100644
index 00000000000..ed1e81ce54e
--- /dev/null
+++ b/dev-python/twython/twython-3.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy (and up to date) way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]"