summaryrefslogtreecommitdiff
path: root/dev-python/vertex/vertex-0.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vertex/vertex-0.3.0-r1.ebuild')
-rw-r--r--dev-python/vertex/vertex-0.3.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/vertex/vertex-0.3.0-r1.ebuild b/dev-python/vertex/vertex-0.3.0-r1.ebuild
new file mode 100644
index 00000000000..b836da595d8
--- /dev/null
+++ b/dev-python/vertex/vertex-0.3.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="An implementation of the Q2Q protocol"
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodVertex http://pypi.python.org/pypi/Vertex"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ >=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc NAME.txt
+}